# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"SQL: \[\d+\] (?<sql>.*) Sent SQL: \[\d+\] (?<send_sql>.*) Params:"
test_str = ("SQL: [126] INSERT INTO `tbl_ip_data` (`ip_start`, `ip_end`, `region_id`, `country_id`, `create_at`)\n"
"VALUES (:v0d, :v1d, :v2d, :v3d, :v4d) Sent SQL: [163] INSERT INTO `tbl_ip_data` (`ip_start`, `ip_end`, `region_id`, `country_id`, `create_at`)\n"
" VALUES ('1900145563', '1900145563', '440118', 'CN', '2022-04-15 21:46:42') Params: 5 Key: Name: [4] :v0d paramno=-1 name=[4] \":v0d\" is_param=1 param_type=2 Key: Name: [4] :v1d paramno=-1 name=[4] \":v1d\" is_param=1 param_type=2 Key: Name: [4] :v2d paramno=-1 name=[4] \":v2d\" is_param=1 param_type=2 Key: Name: [4] :v3d paramno=-1 name=[4] \":v3d\" is_param=1 param_type=2 Key: Name: [4] :v4d paramno=-1 name=[4] \":v4d\" is_param=1 param_type=2 [] []")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.