package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+$`)
var str = `45
45.5
+99
-100
0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}