$re = '/^\d+$/m';
$str = '45
45.5
+99
-100
0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);