#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)https?:\/\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9@:%_\+.~#()?&//=]*)"
Local $sString = "http://foo.com/blah_blah" & @CRLF & _
"http://foo.com/blah_blah/" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)" & @CRLF & _
"http://www.example.com/wpstyle/?p=364" & @CRLF & _
"https://www.example.com/foo/?bar=baz&inga=42&quux" & @CRLF & _
"http://userid:password@example.com:8080" & @CRLF & _
"http://foo.com/blah_(wikipedia)#cite-1" & @CRLF & _
"www.google.com" & @CRLF & _
"http://../" & @CRLF & _
"http:// shouldfail.com" & @CRLF & _
"http://224.1.1.1" & @CRLF & _
"http://142.42.1.1:8080/" & @CRLF & _
"ftp://foo.bar/baz" & @CRLF & _
"http://1337.net" & @CRLF & _
"http://foo.bar/?q=Test%20URL-encoded%20stuff" & @CRLF & _
"http://code.google.com/events/#&product=browser"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")