const regex = /https?:\/\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9@:%_\+.~#()?&//=]*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{2,256}\\.[a-z]{2,6}\\b([-a-zA-Z0-9@:%_\\+.~#()?&\/\/=]*)', 'gmi')
const str = `http://foo.com/blah_blah
http://foo.com/blah_blah/
http://foo.com/blah_blah_(wikipedia)
http://www.example.com/wpstyle/?p=364
https://www.example.com/foo/?bar=baz&inga=42&quux
http://userid:password@example.com:8080
http://foo.com/blah_(wikipedia)#cite-1
www.google.com
http://../
http:// shouldfail.com
http://224.1.1.1
http://142.42.1.1:8080/
ftp://foo.bar/baz
http://1337.net
http://foo.bar/?q=Test%20URL-encoded%20stuff
http://code.google.com/events/#&product=browser`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}