#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))"
Local $sString = "1900-10-23" & @CRLF & _
"2002-5-5" & @CRLF & _
"2009-23-5" & @CRLF & _
"2008-09-31" & @CRLF & _
"1600-12-25" & @CRLF & _
"1942-11-1" & @CRLF & _
"1942-11-0" & @CRLF & _
"1942-00-25" & @CRLF & _
"2000-10-00" & @CRLF & _
"2000-10-10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")