using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))";
string input = @"1900-10-23
2002-5-5
2009-23-5
2008-09-31
1600-12-25
1942-11-1
1942-11-0
1942-00-25
2000-10-00
2000-10-10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}