package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d*(\.\d+)?$`)
var str = `5.0
3
0.0
-3.5
+2.5
+2
-3
100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}