$re = '/^\d*(\.\d+)?$/m';
$str = '5.0
3
0.0
-3.5
+2.5
+2
-3
100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);