$re = '/(?=(.*[0-9]))((?=.*[A-Za-z0-9])(?=.*[A-Z])(?=.*[a-z]))^.{8,}$/m';
$str = 'hello
hello5
helloworld
helloWorld
helloWorld555
hello555@
Hello555
helloWorld555@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);