re = /(?=(.*[0-9]))((?=.*[A-Za-z0-9])(?=.*[A-Z])(?=.*[a-z]))^.{8,}$/m
str = 'hello
hello5
helloworld
helloWorld
helloWorld555
hello555@
Hello555
helloWorld555@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end