import re
regex = re.compile(r"<%([-=]):\s*([^|]*?)\s*%>", flags=re.MULTILINE)
test_str = "<%=: price %>"
subst = "<%\\1 \\2 %>"
result = regex.sub(subst, test_str)
if result:
print(result)