#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=K{10}\n)\K.++(?!\n-)"
Local $sString = "-----------------------" & @CRLF & _
"4046904" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"KKKKKKKKKKK" & @CRLF & _
"Laura Meyer" & @CRLF & _
"MassMutual Life Insurance" & @CRLF & _
"153 Vadnais Street" & @CRLF & _
"" & @CRLF & _
"Chicopee, MA 01020" & @CRLF & _
"US" & @CRLF & _
"413-744-5452" & @CRLF & _
"lmeyer@massmutual.co..." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"KKKKKKKKKKK" & @CRLF & _
"373074210772222 02/12 6213 NA" & @CRLF & _
"-----------------------" & @CRLF & _
"4046907" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"KKKKKKKKKKK" & @CRLF & _
"Venkat Talladivedula" & @CRLF & _
"" & @CRLF & _
"6105 West 68th Street" & @CRLF & _
"" & @CRLF & _
"Tulsa, OK 74131" & @CRLF & _
"US" & @CRLF & _
"9184472611" & @CRLF & _
"venkat.talladivedula..." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"KKKKKKKKKKK" & @CRLF & _
"373022121440000 06/11 9344 NA" & @CRLF & _
"-----------------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")