# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=K{10}\n)\K.++(?!\n-)"
test_str = ("-----------------------\n"
"4046904\n\n\n"
"KKKKKKKKKKK\n"
"Laura Meyer\n"
"MassMutual Life Insurance\n"
"153 Vadnais Street\n\n"
"Chicopee, MA 01020\n"
"US\n"
"413-744-5452\n"
"lmeyer@massmutual.co...\n\n\n"
"KKKKKKKKKKK\n"
"373074210772222 02/12 6213 NA\n"
"-----------------------\n"
"4046907\n\n\n"
"KKKKKKKKKKK\n"
"Venkat Talladivedula\n\n"
"6105 West 68th Street\n\n"
"Tulsa, OK 74131\n"
"US\n"
"9184472611\n"
"venkat.talladivedula...\n\n\n"
"KKKKKKKKKKK\n"
"373022121440000 06/11 9344 NA\n"
"-----------------------")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.