import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\[\\s*(?<name>[a-zA-Z0-9-_]+)\\s*(?:\\=\\s*(?<bbCode>\\\"(?:[^\\\"\\\\\\\\]*(?:\\\\\\\\.[^\\\"\\\\\\\\]*)*)\\\"|((?:(?!=\\s*|\\]|\\/\\])[^\\s])+)))?\\s*(?<parameters>(?:\\s*(?:\\w+(?:\\s*\\=\\s*\\\"(?:[^\\\"\\\\\\\\]*(?:\\\\\\\\.[^\\\"\\\\\\\\]*)*)\\\"|\\s*\\=\\s*((?:(?!=\\s*|\\]|\\/\\])[^\\s])+)|(?=\\s|\\]|\\/\\s*\\]|$))))*)\\s*(?:\\](?<content>.*?)\\[\\s*(?<markerContent>\\/)\\s*(\\k<name>)\\s*\\]|\\]|(?<marker>\\/)\\s*\\])))";
final String string = "[style-background=red]\n"
+ "[style-color=blue]";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}