const regex = new RegExp('((?:\\[\\s*(?<name>[a-zA-Z0-9-_]+)\\s*(?:\\=\\s*(?<bbCode>\\"(?:[^\\"\\\\\\\\]*(?:\\\\\\\\.[^\\"\\\\\\\\]*)*)\\"|((?:(?!=\\s*|\\]|\\/\\])[^\\s])+)))?\\s*(?<parameters>(?:\\s*(?:\\w+(?:\\s*\\=\\s*\\"(?:[^\\"\\\\\\\\]*(?:\\\\\\\\.[^\\"\\\\\\\\]*)*)\\"|\\s*\\=\\s*((?:(?!=\\s*|\\]|\\/\\])[^\\s])+)|(?=\\s|\\]|\\/\\s*\\]|$))))*)\\s*(?:\\](?<content>.*?)\\[\\s*(?<markerContent>\\/)\\s*(\\k<name>)\\s*\\]|\\]|(?<marker>\\/)\\s*\\])))', 'ugmi')
const str = `[style-background=red]
[style-color=blue]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}