using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:rgb\((\d{1,3}),\s?(\d{1,3}),\s?(\d{1,3})\))|(?:rgba\((\d{1,3}),\s?(\d{1,3}),\s?(\d{1,3}),\s?([0-1]\.0|0\.[0-9])\)))";
string input = @"rgb(0, 0, 0)
rgb(0,0,0)
rgb(255, 255, 255)
rgba(255, 255, 255, 1)
rgba(255, 255, 255,1)
rgba(255, 255, 255, 0)
rgba(255, 255, 255, 0.9)
rgba(255, 255, 255, 0.0)
rgba(255, 255, 255, 1.0)
rgba(255, 255, 255, 1.1)
rgba(255, 255, 255, 666)
rgba(255, 255, 255ab)
rgb(255, 255, 255, 344)
#p1 {background-color: rgba(255, 0, 0, 0.3);} /* red with opacity */
#p2 {background-color: rgba(0, 255, 0, 0.3);} /* green with opacity */
#p3 {background-color: rgba(0, 0, 255, 0.3);} /* blue with opacity */";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}