import Foundation
let pattern = #"(?:(?:rgb\((\d{1,3}),\s?(\d{1,3}),\s?(\d{1,3})\))|(?:rgba\((\d{1,3}),\s?(\d{1,3}),\s?(\d{1,3}),\s?([0-1]\.0|0\.[0-9])\)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
rgb(0, 0, 0)
rgb(0,0,0)
rgb(255, 255, 255)
rgba(255, 255, 255, 1)
rgba(255, 255, 255,1)
rgba(255, 255, 255, 0)
rgba(255, 255, 255, 0.9)
rgba(255, 255, 255, 0.0)
rgba(255, 255, 255, 1.0)
rgba(255, 255, 255, 1.1)
rgba(255, 255, 255, 666)
rgba(255, 255, 255ab)
rgb(255, 255, 255, 344)
#p1 {background-color: rgba(255, 0, 0, 0.3);} /* red with opacity */
#p2 {background-color: rgba(0, 255, 0, 0.3);} /* green with opacity */
#p3 {background-color: rgba(0, 0, 255, 0.3);} /* blue with opacity */
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)