$re = '/\[([^]]+)\]([^[]+)\[\/\1\]/m';
$str = '[highlight][b]xxxxxx[/b][/highlight]
';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;