# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:\+|00)33[\s.-]{0,3}(?:\(0\)[\s.-]{0,3})?|0)[1-9](?:(?:[\s.-]?\d{2}){4}|\d{2}(?:[\s.-]?\d{3}){2})$"
test_str = ("~ Accepted ~\n"
"0123456789\n"
"01 23 45 67 89\n"
"01.23.45.67.89\n"
"0123 45.67.89\n"
"0033 123-456-789\n"
"0033(0)123456789\n"
"+33-1.23.45.67.89\n"
"+33 - 123 456 789\n"
"+33(0) 123 456 789\n"
"+33 (0)123 45 67 89\n"
"+33 (0)1 2345-6789\n"
"+33(0) - 123456789\n"
"--------------------------------\n"
"~ Rejected ~\n"
"012345678\n"
"01234567890\n"
"0+123456789\n"
"(0)123456789\n"
"01 23 45 67 89\n"
"--------------------------------\n"
"~ Accepted but strange ~\n"
"+33.-.123456789\n"
"+33.-.(0)-.-123456789\n"
"01 23.45-67.89\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.