# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"app\":\"splunk-kubernetes-objects\""
test_str = ("{\"severity\":\"INFO\",\"ts\":1704101563.224535,\"logger\":\"controller\",\"msg\":\"Seccomp profile 'not configured' is not allowed for container 'splunk-fluentd-k8s-objects'. Found at: no explicit profile found. Allowed profiles: {\\\"RuntimeDefault\\\", \\\"docker/default\\\", \\\"runtime/default\\\"}\",\"process\":\"audit\",\"audit_id\":\"2024-01-01T09:32:31Z\",\"details\":{},\"event_type\":\"violation_audited\",\"constraint_group\":\"constraints.gatekeeper.sh\",\"constraint_api_version\":\"v1beta1\",\"constraint_kind\":\"K8sPSPSeccomp\",\"constraint_name\":\"cis-k8s-v1.5.1-psp-seccomp-default\",\"constraint_namespace\":\"\",\"constraint_action\":\"warn\",\"resource_group\":\"\",\"resource_api_version\":\"v1\",\"resource_kind\":\"Pod\",\"resource_namespace\":\"idmzct0-ito-utils-splunkdc-callsign\",\"resource_name\":\"gkeusr-idmzc-dev-tier0-01-splunk-kubernetes-objects-5686d96j7nj\",\"resource_labels\":{\"app\":\"splunk-kubernetes-objects\",\"engine\":\"fluentd\",\"pod-template-hash\":\"5686d96bd8\",\"release\":\"gkeusr-idmzc-dev-tier0-01\"}}\n"
"Show syntax highlighted\n"
"cluster_name = gkeusr-idmzc-dev-tier0-01container_name = managerhost = npool-cos-apps-medium-7b7dd5cdb8-s6lrpnamespace = gatekeeper-systempod = gatekeeper-audit-789888c597-q9vt8severity = INFOsource = /var/log/containers/gatekeeper-audit-789888c597-q9vt8_gatekeeper-system_manager-da5f687a6b53035c4299f8e3c5cc941c510756de883f2f0e68e783cd4edc7191.logsourcetype = kube:container:manager")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.