// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"app\":\"splunk-kubernetes-objects\""#).unwrap();
let string = "{\"severity\":\"INFO\",\"ts\":1704101563.224535,\"logger\":\"controller\",\"msg\":\"Seccomp profile 'not configured' is not allowed for container 'splunk-fluentd-k8s-objects'. Found at: no explicit profile found. Allowed profiles: {\\\"RuntimeDefault\\\", \\\"docker/default\\\", \\\"runtime/default\\\"}\",\"process\":\"audit\",\"audit_id\":\"2024-01-01T09:32:31Z\",\"details\":{},\"event_type\":\"violation_audited\",\"constraint_group\":\"constraints.gatekeeper.sh\",\"constraint_api_version\":\"v1beta1\",\"constraint_kind\":\"K8sPSPSeccomp\",\"constraint_name\":\"cis-k8s-v1.5.1-psp-seccomp-default\",\"constraint_namespace\":\"\",\"constraint_action\":\"warn\",\"resource_group\":\"\",\"resource_api_version\":\"v1\",\"resource_kind\":\"Pod\",\"resource_namespace\":\"idmzct0-ito-utils-splunkdc-callsign\",\"resource_name\":\"gkeusr-idmzc-dev-tier0-01-splunk-kubernetes-objects-5686d96j7nj\",\"resource_labels\":{\"app\":\"splunk-kubernetes-objects\",\"engine\":\"fluentd\",\"pod-template-hash\":\"5686d96bd8\",\"release\":\"gkeusr-idmzc-dev-tier0-01\"}}
Show syntax highlighted
cluster_name = gkeusr-idmzc-dev-tier0-01container_name = managerhost = npool-cos-apps-medium-7b7dd5cdb8-s6lrpnamespace = gatekeeper-systempod = gatekeeper-audit-789888c597-q9vt8severity = INFOsource = /var/log/containers/gatekeeper-audit-789888c597-q9vt8_gatekeeper-system_manager-da5f687a6b53035c4299f8e3c5cc941c510756de883f2f0e68e783cd4edc7191.logsourcetype = kube:container:manager";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}