#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^if *\(([^}]+)\) { ([^}]+) \}(?: else { ([^}]+) \})? endif$"
Local $sString = "if(stat(life) >= 2) { abc(5) deal_damage(5) } else { gain_block(5) } endif" & @CRLF & _
"" & @CRLF & _
"if(s) { what; } else { asd } endif" & @CRLF & _
"" & @CRLF & _
"if(stat(life) >= 2) { deal_damage(5) } else { gain_block(5) } endif" & @CRLF & _
"if (whatever i want) { deal_damage(1) } endif" & @CRLF & _
"if( has_status_fx(chill) ) { gain_block(1) } endif" & @CRLF & _
"" & @CRLF & _
"if (true) { deal_damage(5) }" & @CRLF & _
"if(false){ gain_block(1) } endif" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")