import Foundation
let pattern = #"^if *\(([^}]+)\) { ([^}]+) \}(?: else { ([^}]+) \})? endif$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
if(stat(life) >= 2) { abc(5) deal_damage(5) } else { gain_block(5) } endif
if(s) { what; } else { asd } endif
if(stat(life) >= 2) { deal_damage(5) } else { gain_block(5) } endif
if (whatever i want) { deal_damage(1) } endif
if( has_status_fx(chill) ) { gain_block(1) } endif
if (true) { deal_damage(5) }
if(false){ gain_block(1) } endif
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)