const regex = /^([A-Z]{2}\d{7}[A-Z])|(^[U]1[BCDEFGHLMNPRSTUWYXZ]\w{6}[A-Z])$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z]{2}\\d{7}[A-Z])|(^[U]1[BCDEFGHLMNPRSTUWYXZ]\\w{6}[A-Z])$', 'i')
const str = `U1B538525N`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}