re = /^([A-Z]{2}\d{7}[A-Z])|(^[U]1[BCDEFGHLMNPRSTUWYXZ]\w{6}[A-Z])$/i
str = 'U1B538525N'
# Print the match result
str.match(re) do |match|
puts match.to_s
end