using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"function (?<name>[a-zA-Z0-9]+)\s*(?<arguments>\([^()]*\)(?::\s*[^{}\s]*)?)\s*(?<body>\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*\}[^\r{}]*)*\}[^\r{}]*)*\}[^\r{}]*)*\}[^\r{}]*)*\}[^\r{}]*)*\})(?:;)?";
string input = @"function setupForNoActionsAvailable() {
component.canDelete = jasmine.createSpy('canDelete').and.returnValue(false);
component.canMarkAsBlocked = jasmine.createSpy('canMarkAsBlocked').and.returnValue(false);
component.canMarkAsReBill = jasmine.createSpy('canMarkAsRebill').and.returnValue(false);
component.canMoveToInProgress = jasmine.createSpy('canMoveToInProgress').and.returnValue(false);
}
function setupValidConditions() {
component.invoice = {} as any;
component.isReadonly = jasmine.createSpy('isReadonly').and.returnValue(false);
invoiceHelper.canMarkAsReBill = jasmine.createSpy('canMarkAsReBill').and.returnValue(true);
};
export function ageInDays(date: Date, now: Date): number {
return Math.trunc(millisecondsToDays(now.getTime() - date.getTime()));
}
function millisecondsToDays(milliseconds: number): number {
return (((milliseconds / 1000) / 60) / 60) / 24;
}
// Prevent Karma from running prematurely.
__karma__.loaded = function () { };";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}