// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)function (?<name>[a-zA-Z0-9]+)\s*(?<arguments>\([^()]*\)(?::\s*[^{}\s]*)?)\s*(?<body>\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*(?:\{[^\r{}]*\}[^\r{}]*)*\}[^\r{}]*)*\}[^\r{}]*)*\}[^\r{}]*)*\}[^\r{}]*)*\})(?:;)?").unwrap();
let string = "function setupForNoActionsAvailable() {
component.canDelete = jasmine.createSpy('canDelete').and.returnValue(false);
component.canMarkAsBlocked = jasmine.createSpy('canMarkAsBlocked').and.returnValue(false);
component.canMarkAsReBill = jasmine.createSpy('canMarkAsRebill').and.returnValue(false);
component.canMoveToInProgress = jasmine.createSpy('canMoveToInProgress').and.returnValue(false);
}
function setupValidConditions() {
component.invoice = {} as any;
component.isReadonly = jasmine.createSpy('isReadonly').and.returnValue(false);
invoiceHelper.canMarkAsReBill = jasmine.createSpy('canMarkAsReBill').and.returnValue(true);
};
export function ageInDays(date: Date, now: Date): number {
return Math.trunc(millisecondsToDays(now.getTime() - date.getTime()));
}
function millisecondsToDays(milliseconds: number): number {
return (((milliseconds / 1000) / 60) / 60) / 24;
}
// Prevent Karma from running prematurely.
__karma__.loaded = function () { };";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}