package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((\d+,)+\d+\n?)+`)
var str = `15,2,3
10,255,302
204,2190,20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}