$re = '/((\d+,)+\d+\n?)+/mi';
$str = '15,2,3
10,255,302
204,2190,20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);