$re = '/([A-Z][a-z]*)(\d*[-+]?)/';
$str = 'K+
Cr7+
O2-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);