re = /(?<=WindowsPath\(').*?(?='\))/m
str = 'x= (WindowsPath(\'D:/test/1_birds_bp.png\'),WindowsPath(\'D:/test/1_eagle_mp.png\'))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end