package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+?\]`)
var str = `['210', '210', '210', '210']['0.3', '0.3', '0.3', '0.3']['7.85e-06', '7.85e-06', '7.85e-06', '7.85e-06']`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}