$re = '/([^\/]*?)\/(\d+)/m';
$str = 'php/127/typescript/12/jquery/120/angular/50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);