$re = '/^(.+?)((?:\=.+?)*)((?:\..+?)*)((?:\^.+?)*)(\$)*(\:)*((?:\#.+)*)$/m';
$str = 'First element=Second=Group.Third.Grp^Fourth^Set$:#T1#Test2#B 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);