re = /^(.+?)((?:\=.+?)*)((?:\..+?)*)((?:\^.+?)*)(\$)*(\:)*((?:\#.+)*)$/m
str = 'First element=Second=Group.Third.Grp^Fourth^Set$:#T1#Test2#B 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end