$re = '/\[#((?:\[#.*?#]|(?!#])[^|])*?)\|((?:\[#.*?#]|(?!#])[^|])*?)#]/';
$str = 'Today [#[#item#] was|the items were#] shipped so [#it is|they are#] gone.
Today [#item#] was shipped so [#it is|they are#] gone.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);