re = /\[#((?:\[#.*?#]|(?!#])[^|])*?)\|((?:\[#.*?#]|(?!#])[^|])*?)#]/
str = 'Today [#[#item#] was|the items were#] shipped so [#it is|they are#] gone.
Today [#item#] was shipped so [#it is|they are#] gone.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end