import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\G #anclado a \\A o fin de última coincidencia\n"
+ "( #Grupo 1: Caracteres previos\n"
+ " [^\\h\\\\'\\v]*+ # Todo menos caracteres especiales\n"
+ " (?: # Repetir infinitas veces\n"
+ " (?: # Alternativas:\n"
+ " (?!^)\\h # a. espacio simple que no\n"
+ " (?!\\h|$) # está al ppio ni al final\n"
+ " | \\v # b. línea nueva\n"
+ " | \\\\. # c. cualquier escape\n"
+ " | '[^'\\\\]*+ # d. comillas\n"
+ " (?:(?:''|\\\\.)[^'\\\\]*)* \n"
+ " ' #\n"
+ " ) #\n"
+ " [^\\h\\\\'\\v]*+ # Seguido de más texto no especial\n"
+ " )* #\n"
+ ") #(fin G1)\n"
+ "(?: #Espacios:\n"
+ " ^\\h+ # a. al ppio de la línea\n"
+ "| \\h+(\\h|$) # b. en el medio o al final\n"
+ ") #";
final String string = " select * , fooo , \n"
+ " a, \n"
+ "b,\n"
+ "c\n"
+ " from\n"
+ "table\n"
+ "where a = 'a b'\n"
+ " or campo = 'borra los espacios \\'no?'\n"
+ "and c = 1;";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}