package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([a-z1-9]){4}([:|])){3}(([a-z1-9]){4})`)
var str = `abcd|efgh|1234|4567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}