$re = '/(([a-z1-9]){4}([:|])){3}(([a-z1-9]){4})/';
$str = 'abcd|efgh|1234|4567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);