import re
regex = re.compile(r"[a-z1-9]{4}([.:|-])(?:[a-z1-9]{4}\1){2}[a-z1-9]{4}")
test_str = ("abcd.efgh.1234.4567\n"
"abcd-efgh-1234-4567\n"
"abcd|efgh|1234|4567\n"
"abcd.efgh-1234|4567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")