re = /[a-z1-9]{4}([.:|-])(?:[a-z1-9]{4}\1){2}[a-z1-9]{4}/
str = 'abcd.efgh.1234.4567
abcd-efgh-1234-4567
abcd|efgh|1234|4567
abcd.efgh-1234|4567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end