package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:^| |[a-z][-_])(man)`)
var str = `man spider-man my man Jeeves
manpower iron_man yo-yo-man
woman human
-man`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}