// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:^| |[a-z][-_])(man)").unwrap();
let string = "man spider-man my man Jeeves
manpower iron_man yo-yo-man
woman human
-man";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}