$re = '/<script[^>]*>[^<]*<\/script>/';
$str = '<script>alguma funcao javascript</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);