re = /<script[^>]*>[^<]*<\/script>/
str = '<script>alguma funcao javascript</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end