$re = '/想.*/';
$str = '一段文章里面 设置从 “想” 字开始,后面的都不要了。因为“想”字开始,但结束的不同。所以得弄个正则表达式';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);