import Foundation
let pattern = #"想.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"一段文章里面 设置从 “想” 字开始,后面的都不要了。因为“想”字开始,但结束的不同。所以得弄个正则表达式"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)