re = /^data(-[^:]*)*$/m
str = 'data-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash:c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end